Page 1 of 1

Πρόβλημα σε configuration της MySQL

Posted: Thu Mar 26, 2009 8:29 pm
by marios
Παίδες I need some help:
Για τις Βάσεις, θέλω να βάλω την MySQL αλλά το σκασμένο αρνείται πεισματικα...
Ενώ τελειώνει το installation κανονικά, όταν πάω να κάνω το security configuration(για την root), μου ζητάει παλιό και νέο κωδικό.
Ενώ λοιπόν βάζω εκεί που θέλει για παλιό το "" που είναι η default τιμή και εκεί που μου ζητάει το καινούργιο τον κωδικό που θέλω να βάλω, μου βγάζει το σφάλμα της εικόνας.
Έκανα αυτά που λέει εδώ και μέσω cmd κατάφερα να κάνω login(το οποίο μετά από το reboot δεν μπορεσα να ξανακάνω :-p ), αλλά και πάλι ο security configuration wizard πέταγε το σφάλμα της εικόνας.

Καμιά ιδέα;

P.S.: OS: Windows (S)Vista, MySQL Server 5.1

Re: Πρόβλημα σε configuration της MySQL

Posted: Thu Mar 26, 2009 8:40 pm
by Loner
Κάτι λέει για firewall και κάποια port...Μάλλον θα τό'χεις ελέγξει βέβαια αλλά πολλές φορές είναι μες στα μάτια μας και δεν το βλέπουμε... :smt021

Re: Πρόβλημα σε configuration της MySQL

Posted: Thu Mar 26, 2009 8:55 pm
by marios
Και τα 2 που λέει τα έχω ελέγξει και δεν είναι απο αυτό(για το πρώτο, πέρα απο τις ρυθμίσεις στο firewall δοκίμασα και την λύση να το βγάλω εντελώς, ενώ για το δεύτερο, έκανα uninstall και έσβησα και τον φάκελο που ήταν εγκατεστημένη η MySQL). Thanks για την επισήμανση, παράλειψή μου ;)

Re: Πρόβλημα σε configuration της MySQL

Posted: Thu Mar 26, 2009 9:09 pm
by cyberpython
Εδώ: http://port25.technet.com/videos/resear ... indows.pdf , λέει οτι πρέπει κατά την εγκατάσταση να έχει απενεργοποιηθεί εντελώς το UAC (όχι απλά να επιτρέψει τις αλλαγές ο χρήστης). Μήπως δεν τρέχει η υπηρεσία (της MySQL);

Re: Πρόβλημα σε configuration της MySQL

Posted: Thu Mar 26, 2009 9:12 pm
by marios
cyberpython wrote:Εδώ: http://port25.technet.com/videos/resear ... indows.pdf , λέει οτι πρέπει κατά την εγκατάσταση να έχει απενεργοποιηθεί εντελώς το UAC (όχι απλά να επιτρέψει τις αλλαγές ο χρήστης)
To UAC το έχω απενεργοποιήσει καιρό τώρα... Βαρέθηκα να πιστοποιώ ότι εγώ τρέχω το κάθε πρόγραμμα :-p
cyberpython wrote:Μήπως δεν τρέχει η υπηρεσία (της MySQL);
Τι εννοείς;

Re: Πρόβλημα σε configuration της MySQL

Posted: Thu Mar 26, 2009 9:19 pm
by maxthebest
Κατεβασε το XAMPP περιεχει μεσα του το MySQL και εχει και το phpMyAdmin για να δημιουργεις τους πινακες με gui.
+κανει παντα 100% σωστο install

σημειωση: για να ενεργοποιησης την βαση τρεχεις το C:\xampp\mysql_start.bat
για να αποδειξεις οτι τρεχει γραψε localhost στον mozilla .
σε 20 λεπτα τα εχεις εγκαταστησει ολα.

Re: Πρόβλημα σε configuration της MySQL

Posted: Thu Mar 26, 2009 9:22 pm
by para
Και δε θα χρειαστεί να κάνεις την ίδια διαδικασία του χρόνου :-p

Re: Πρόβλημα σε configuration της MySQL

Posted: Fri Mar 27, 2009 12:47 am
by marios
Ευχαριστώ όλους παιδιά για την βοήθεια.
Τελικά βρήκα τον τρόπο και την εγκατέστησα ξεχωριστά.
Για να γλυτώσω κανέναν άνθρωπο από το σπάσιμο νεύρων, η λύση είναι η εξής:
αφότου σου έχει βγάλει το πρόβλημα, πρέπει να κάνεις uninstall, να σβήσεις τον φάκελο MySQL από το Program Files και να σβήσεις το φάκελο MySQL από τον κρυφό φάκελο C:\ProgramData.
Μετά από αυτό, αν το κάνεις install δουλεύει...
Τι λογικά πράγματα να πρέπει να τα βρεις όλα αυτά...